Page 1 of 1

Login to iSCSI target succeeds, but it is not mounted

Posted: Sun Nov 25, 2018 4:48 am
by Windfisch
I just installed KernSafe iSCSI Initiator on my MacBook Pro which runs macOS Mojave. The install worked fine, I had to manually allow the extension to be installed but it seemed to work. I can login to my iSCSI target, but no message pops up asking me to format the new disk, and when doing sudo diskutil list, no disk shows up.

What am I missing? Or is it currently not compatible with macOS Mojave?

Re: Login to iSCSI target succeeds, but it is not mounted

Posted: Sun Jan 06, 2019 7:10 pm
by Olivia (staff)
We have resolved the issue in the new version 3.00, if anyone still have the issue, please report to us.

Re: Login to iSCSI target succeeds, but it is not mounted

Posted: Tue Jan 15, 2019 5:20 pm
by christancho
Hi,
I'm having the same issue. I'm running iSCSI Initiator X 3.00 (1600) with macOS Mojave (10.14.2).
I have the target on "Logged On" status, but the disk utility does not recognize/view the new drive.

Am I missing something?
Thanks
Chris.

Re: Login to iSCSI target succeeds, but it is not mounted

Posted: Thu Jan 17, 2019 12:46 am
by Olivia (staff)
Please follow these steps to ensure the previous version kernel module has been removed:
1. Launch terminal and run the command sudo rm -rf /System/Library/Extensions/KScsiPrt.kext
2. Reboot your machine.

Reinstall 3.0 again and try.

Re: Login to iSCSI target succeeds, but it is not mounted

Posted: Mon Jan 28, 2019 5:30 pm
by venanx
Same problem here...MacOs Mojave - 10.14.2

Re: Login to iSCSI target succeeds, but it is not mounted

Posted: Mon Jan 28, 2019 11:07 pm
by demonzh
problem is still

mojave 10.14.3
kernsafe 3.0


I have tried the solution, but does't work

Re: Login to iSCSI target succeeds, but it is not mounted

Posted: Wed Jan 30, 2019 5:41 am
by Olivia (staff)