Cannot discover FreeNas Server

Completely free iSCSI initiator software for Mac OS X.
Post Reply
Dennis The Menace
Posts: 1
Joined: Tue Feb 18, 2020 2:05 pm

Cannot discover FreeNas Server

Post by Dennis The Menace » Tue Feb 18, 2020 2:09 pm

Dear Forum

We are trying out iSCSI Initiator X with FreeNas but the discovery shows nothing.
Does iSCSI Initiator X work with FreeNas? We are on OS X Catalina 10.15.3.
Telnetting into the FreeNas server at port 3260 does work.

Thanks for any help

Posts: 1
Joined: Thu Jul 15, 2021 7:29 pm

Re: Cannot discover FreeNas Server

Post by jacix » Thu Jul 15, 2021 8:55 pm

What version of FreeNAS are you running?

My FreeNAS/TrueNAS (12.0-U4.1 as of a few minutes ago) is hosting iSCSI targets that two of my Macs are able to log into and they can both mount the APFS volumes in those LUNs. One Mac is running Catalina (10.15.7), the other Big Sur 11.4. I ran into the "mount device error: e0000001" issue this afternoon, and posted to the forum thread with details on how I fixed it. It's probably not relevant, but I thought I'd mention it since it goes into more detail about my setup.

Post Reply